
7/17/2003 Shoreland Management GIS Exercise – Blue Lake (ArcView 3.x) Page 1 
 

 

SHORELAND MANAGEMENT GIS TRAINING EXERCISE 
Blue Lake, Oneida County, Wisconsin 

Updated Spring 2003 

October 1999 
 

Developed by: 
David Hart and Todd Sutphin 
University of Wisconsin Sea Grant Institute -And-  
Land Information and Computer Graphics Facility, 
University of Wisconsin-Madison 

 
Principal Investigators: 
 Bernard J. Niemann, Jr. 

Stephen J. Ventura 
Land Information and Computer Graphics Facility, 
University of Wisconsin-Madison 
Room B102, Steenbock Library 
550 Babcock Drive 
Madison, WI 53706 

 
Allen H. Miller 
University of Wisconsin Sea Grant Institute 
1975 Willow Drive, 2nd Floor 
Madison, WI 53706-1103 

 
Updated by: 

Brea Lemke and David Hart 
Land Information and Computer Graphics Facility 

 
 
This GIS training exercise was developed as part of a cooperative venture between 

the University of Wisconsin Sea Grant Institute and the Land Information and Computer 
Graphics Facility (LICGF) at the University of Wisconsin-Madison with funding from the 
National Sea Grant College Program. 
 
Overview of Exercise 
 
 The purpose of this exercise is to examine the capabilities of the ArcView 3.2 
desktop GIS software and use these concepts to construct a functioning shoreland 
management GIS application “from scratch” using primarily local government-generated 
spatial data.  The GIS application that will be developed as part of this exercise is focused 
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on Blue Lake in northwest Oneida County near Minocqua, Wisconsin.  The five sections 
of the exercise include: 

1. Import and integration of the local government spatial data used in the exercise; 
2. Analysis of assessed value and property ownership patterns around the lake; 
3. Review and analysis of shoreland zoning regulations impacting the lake; 
4. Notification of property owners concerning septic system maintenance, and; 
5. Linkage of scanned photos with map information to aid in zoning enforcement 

and visual assessment. 
 
The GIS software functionality that will be utilized includes data import and integration, 
image interpretation, linkage of attribute data with spatial data sets, thematic mapping, 
spatial query and analysis, customizing graphical user interfaces, incorporating external 
programs (scripts), and inter-application connectivity.  The Shoreland Management GIS 
training exercise reinforces concepts learned in the Introduction to ArcView training 
course developed by Environmental Systems Research Institute (ESRI) of Redlands, 
California. 
 
Acknowledgments 
 
 Much of the background information on lake management and rural zoning in 
Oneida County was extracted from a DNR Lake Protection Grant proposal for shoreland 
zoning compliance assessment prepared by Oneida County staff.  Bryan Pierce, the Vilas 
County UW-Extension CNRED Agent and John Czarnezki, formerly the Oneida County 
UW-Extension CNRED Agent both provided information on shoreland zoning concerns 
in the northern lakes district.  The spatial data sets used in the application come from a 
variety of sources.  Planimetric and parcel data were obtained from Mike Romportl, the 
Oneida County Land Information Officer.  Another version of the parcel map was 
digitized by staff of the Land Information and Computer Graphics Facility (LICGF) from 
paper maps.  Digital wetland maps were obtained from the Wisconsin Department of 
Natural Resources.  Digital orthophoto quarter quads (DOQQs) were produced by the 
U.S. Geological Survey and obtained from the Ken Lubich in the Madison office of the 
Natural Resource Conservation Service.  Digital raster graphs (DRGs) were obtained 
from Lance Perry in the BIM/GEO section of the Wisconsin Department of Natural 
Resources and represent another U.S. Geological Survey product.  The tax roll, sanitary, 
and permit attribute files were provided by Lynn Grube of the Oneida County Data 
Processing Department.  The septic tank point data set was created specifically for the 
exercise to show an example of septic system maintenance notification and is completely 
fictitious.  Photo images of Blue Lake were taken in October 1996 by David Hart of UW-
Madison LICGF.  Finally, a digital copy of the Oneida County Zoning and Shoreland 
Protection Ordinance was obtained from John Czarnezki and developed into a Windows 
help file using RoboHelp 3 from Blue Sky Software of LaJolla, California.   The desktop 
GIS software utilized in this exercise, ArcView 3.1, is a product of Environmental 
Systems Research Institute (ESRI) of Redlands, California. 
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Background 
 
 Oneida County is part of the northern temperate lakes district of Wisconsin and 
Michigan, a region characterized by one of the highest concentration of inland lakes in 
the world.  Oneida County contains 426 named and 701 unnamed lakes.  The total surface 
area of the county is 779,235 acres.  Of this, 74,415 acres (10.5 percent) is water.  
Important research in the early development of the field of limnology was conducted in 
the region and the area is known as the “cradle of limnology.”   
 
 Development Pressures.  Development in Oneida County has increased over the 
past several decades.  There has been a boom in construction of both seasonal recreational 
homes and permanent residences.  The number of new building permits has increased 
from 1,112 in 1989 to 1,643 in 1993.  A total of 825 new sanitary permits were issued in 
1993, up from 557 in 1989.  Much of the new construction activity has taken place on 
lakefront property.  Of the single family homes constructed in 1993, 52 percent were on 
lakefront properties.  The 1990 census indicates that 11,263 of 25,173 total housing units 
in the county (45 percent) are seasonal.  Developable lakefront property is becoming 
scarce and, as a result, shoreside property values have risen dramatically. 
 
 Commercial development is also active in Oneida County.  The county is a major 
tourism destination, with over 300 lodging facilities offering approximately 3200 rooms; 
37 campgrounds with over 1500 total campsites; and seventeen recreation camps serving 
approximately 2,800 people.  Lodging occupancy information and visitors surveys 
indicate that Oneida County serves an average summer seasonal population of over 
55,000 people, which is almost double the 1990 permanent population of 31,679. 
 
 The History of Rural Zoning in Oneida County.  In May 1933, Oneida County 
enacted the first comprehensive rural zoning ordinance in the United States.  In the early 
1930’s, most northern Wisconsin counties were facing financial difficulties stemming, in 
part, from difficulties in converting cut-over forest lands to agriculture.  The purpose of 
the rural zoning ordinance was to restrict settlement in remote areas.  The Oneida County 
Board of Supervisors was concerned about the high costs of transporting school children 
and the construction and maintenance of roads in remote areas.  The ordinance eventually 
became a model for other counties in Wisconsin and promoted the creation of county 
forest preserves across northern Wisconsin. 
 
 Since that time, the nature of zoning in rural Oneida County has changed.  The 
County adopted a Shorelands Protection Ordinance in November 1970 based on state 
enabling legislation.  The ordinance has since been revised several times.  It is now 
identified as the Oneida County Zoning and Shorelands Protection Ordinance.  
Amendments to the ordinance include provisions on mining, signage, non-conforming 
structures, and placement of mobile and manufactured homes. 
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 Protecting Water Quality and Aesthetics.  Given the increasing development 
pressure in the county and the fact that much of the new development is located on the 
county’s fragile lake ecosystems, regulation of shoreland development is very important.  
Failing septic systems, construction site soil erosion, runoff of lawn fertilizers, and other 
sources represent non-point sources of pollution that impair water quality.  Water quality 
impairment threatens fish and wildlife habitat and aesthetics.  Various structural 
violations of the shoreland ordinance requirements may also threaten the water quality 
and natural beauty of the lake resources. 
 
 To address these concerns, Oneida County has initiated a comprehensive revision 
of the zoning and shoreland protection ordinance.  The overall goals of the project are to 
improve compliance rates of new and existing shoreland development, and to protect 
shoreland and lake ecosystem quality.  Funding for the multi-year effort comes from local 
sources and a state lakes protection grant.  The scope of the project includes: (1) an 
assessment of shoreland zoning compliance and resource problems; (2) revision of 
mining provisions in shorelands and floodplains; (3) comprehensive revision of the 
zoning and shoreland protection ordinance to improve its administration; (4) community 
education on the revised regulations; and (5) creation of a program to monitor and 
enforce the revised ordinance. 
 
 Spatial Information Technologies for Enforcement of Shoreland Zoning.  
Oneida County has an active land records modernization program and is exploring 
methods to incorporate GIS/LIS technology to assist in administration and enforcement of 
the zoning and shoreland protection ordinance.  Specific activities include creation of 
digital parcel maps, development of parcel identification numbers (PINs) to link property 
attributes to the parcel map, development of digital orthophotos on a regular time frame, 
incorporation of aerial or boat-based videography to help detect property changes and 
zoning violations.  Oneida County has contracted with the Land Information and 
Computer Graphics Facility (LICGF) at the University of Wisconsin-Madison to provide 
technical assistance, database development, and training to support develop a GIS-based 
monitoring system for long-term enforcement and evaluation of the ordinance.
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Section 1.  Data Input and Integration 
Estimated time: 45 minutes 
 
In this section, you will start a new ArcView project, input a variety of spatial data sets, 
including buildings, hydrography, parcels, scale-corrected aerial photographs 
(orthophotos), and scanned USGS topographic maps (digital raster graphics), and 
manipulate the appearance and properties of these data sets.  All your data sets should be 
on the C drive in a subdirectory named c:\coastgis\bluelake. 
 
 
Create a Project and a View. 
 
Start the ArcView 3.2 program by double clicking the ArcView icon on the desktop or by 
selecting the ArcView program from the Start menu.  At the “Welcome to ArcView GIS” 
dialog box, chose to create a new project as a Blank Project.  When the program has 
loaded, select the Project pull-down menu and choose Properties.  In the dialog box, 
type c:\coastgis\bluelake (or the directory specified by the instructor) as the Work 
Directory instead of $HOME. Select OK. 
 
Make sure the View icon is highlighted in the project window and click the New button. 
An empty view screen will appear entitled View 1. 
 

Enlarge both the ArcView project window and the View1 window by using the 
maximize window button in the upper right corner of the window. 
 
From the View pull-down menu, choose Properties…  In the View Properties dialogue 
box, change the name from 
“View1” to “Data Integration 
View.”  Type in your name as 
the creator.  Set the map units to 
feet (the data are in Oneida 
County Coordinates which is a 
coordinate system based in feet).  
Set the distance units to feet (this 
will allow you to make distance 
measurements in feet).  Click 
OK.  Note the change in your 
View window. 
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From the File pull-down menu, choose Save Project.  Navigate to the 
c:\coastgis\bluelake subdirectory and save the project file as “bluelake.apr”.  Click OK. 
 

An ArcView project file is assigned the extension “.apr”.   An ArcView project file is an ASCII 
file that sets the various properties and configurations of your individual ArcView project.  An 
ArcView project can contain multiple views, map layouts, and database tables.  For this shoreland 
management training exercise, all of your work will be saved in a single project.  Remember to 
save your work frequently.  Use the disk button on the far left side of the interface.  If your 
computer crashes, and you have recently saved your project, it will be very easy to return to where 
you left off simply by opening the project.  If you do not frequently save your project and the 
computer crashes, you will lose any changes made since your last save. 

 
 
Add Feature Data Files to the View. 
 

Click the Add Theme button to add data files as themes into your view.  In the Add 
Theme dialog box, for Data Source type, make sure Feature Data Source is 

selected. Locate and highlight the following data files.  You can select multiple data files 
by holding the “Shift” key while making your selection.  When all the files listed below 
are selected, click OK. 
 

1. Bl_water (hydrography polygons) 
2. Bl_parcl (parcels polygons) 
3. Bl_bldgs (building outlines polygons) 
 
The data files are ArcView shapefiles located in the c:/coastgis/bluelake subdirectory (or in the 
alternate subdirectory specified by the instructor).  Many different formats of spatial data may be 
imported into ArcView, including ArcINFO coverages, AutoCAD DXF and DWG files, and 
Intergraph files. 

 
Once the themes have been inserted into the View, make each of the themes visible by 
clicking on the box in front of each theme. 
 

A theme is the name given to a spatial data file imported into ArcView.  Themes are displayed in 
the View based on the order they appear in the Table of Contents (i.e. themes on the top of the 
Table of Contents are displayed over the other themes in the View).  To change the display order 
of themes, click on the theme name to make it active and drag it to a new position on the Table of 
Contents.  The active theme is the theme that is “raised” (surrounded by a shadow) in the Table of 
Contents.  It is important to note which theme is active, as many ArcView functions are performed 
on the active theme. 

 
Reorder the themes in the Table of Contents to place Bl_bldgs at the top of the Table of 
Contents, followed by Bl_water, and Bl_parcl. 
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Modify Theme Properties. 
 
Make the Bl_bldgs (building outlines) theme active. When a theme is first created, it is 
displayed in a random color.  This color can be changed.  You can change individual 
theme symbols by using the legend editor and symbol palette.  You will use the legend 
editor to make the buildings red.  From the Theme pulldown menu choose Edit Legend 
to bring up the Legend Editor (a short-cut is to double click on the theme in the Table of 
Contents).  The Legend Editor dialog box should indicate that the Bl_bldgs theme is 
currently active. 
 

To change the color, double-click the color in the symbol box.  This brings up the 
Fill Palette.  Click the Color Palette button (displayed icon).  Scroll through the 

colors in the Color Palette window and choose an appropriate bold shade of red.  Click 
Apply in the Legend Editor to apply your changes to the Table of Contents and the map 
display.  Close the Color Palette and Legend Editor by clicking the “X” (close window 
button) in the upper right corner of the window. 
 
It is often important to change the name of a theme to have it describe more clearly the 
information you are displaying in the View.  We will use theme properties to change the 
theme name to “Buildings.”  First, make the Bl_bldgs theme active.  To change the theme 
name, select the Theme pull-down menu and highlight Properties.  You are now in the 
Theme Properties dialog box.  To rename the theme, highlight the Theme Name input 
box and type in “Buildings”.  Click OK.  Notice that the new theme name is now 
displayed in the View’s Table of Contents.   
 
Make the Bl_water (hydrography) theme active.  In some cases, we will want to only 
display a subset of the spatial features in a particular theme.  In this case, there is an 
island in Blue Lake that should not be displayed as water.  You will use theme properties 
to build a query to select only where ‘land_wat = W’ and to change the theme name to 
“Water.”  You can define selection criteria using the Query Builder to display a subset of 
the theme features. 
 
From the Theme pull-down menu, highlight Properties...  You are now in the Theme 
Properties dialog box and you want to build a query that selects a subset of the ‘water’ 
theme.   
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Select the Query button.  In the Query Builder, from the Fields list, double-click 
[Land_Wat] -- this now appears in the expression box.  Next, you want to set this 

equal to a value (click once on 
the ‘=‘ sign).  From the Values 
list double click “W” to set the 
expression equal to ‘water.’  
Click OK on the Query 
Builder.  Before exiting, 
change the Theme Name to 
‘Water’.  Click OK.  Close out 
of Theme Properties dialog box 
and make the view screen 
active. Use the legend editor to 
make the water blue.  Note that 
when the View is re-drawn, 
only those features which are water are displayed.   
 
Make the Bl_parcl (parcels) theme active.  The parcel data set includes lakes and other 
areas that have not been assigned a parcel identification number.  We will want to 
exclude these from the theme. 
 
Use the Query Builder in Theme Properties to build a query to select only the parcels 
where the field Parcel_id is not equal to “Blue Lake”, Papkee Lake, or a blank value.  The 
query should read ( [Parcel_id] <> "Blue Lake") and ([Parcel_id] <> "Papkee Lake") 
and ([Parcel_id] <> "" ).  Note: ‘<>‘ denotes “not equal to.”  When the query is entered 
correctly (as in the figure below), select OK. 
 

 
While in Theme Properties, change the theme name to “Parcels.” 
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Use the legend editor to make the parcels light gray. 
 

While in the Data Integration View, use the measurement tool to examine the 
distance across the lake in different directions.  The measurement tool utilizes the 

distance units set in View Properties.  The distances are displayed at the bottom left of the 
View window.  To stop measuring, click in the blank gray area to the right of the buttons 
above the View.  For your information, Blue Lake is approximately 445 acres in size. 
 

As mentioned previously, it is always a good idea to save your project on a regular 
basis.  Now is a good time. 

 
 
Add Image Data Files to the View. 
 
The buildings, water, and parcels datasets are termed feature data sources in ArcView.  
Feature data sources are made up of points, lines, and polygons, and are often referred to 
as vector data in the GIS lingo.  ArcView can also import image data.  Image data are 
made up of arrays of “pixels” (picture elements) or “grid cells”.  In this section, you will 
import digital orthophotos (scale-corrected aerial photographs) and Digital Raster Graphs 
(scanned USGS 7.5’ topographic maps).  The image files are in the TIFF file format 
(*.tif) with a TIFF world file (*.tfw) to give information about the placement of the image 
with reference to the Oneida County coordinate system. 
 
Choose the Add Theme icon.  Select Image Data Source under Data Source Type.  
Choose blueedoq.tif, bluewdoq.tif, bluedrg.tif and bluewdrg.tif (hold the shift key down 
to select both files at the same time).  Drag the newly added themes to the bottom of the 
table of contents and make the Building, Water, and Parcels theme invisible (remove the 
check from the box in front of the theme).  Make the bluedoq.tif theme visible. 
 

Zoom into the bay in the northwest corner of Blue Lake.  Select the Zoom In icon.  
Make a box around the bay by pointing to the upper left corner of the bay and 

holding down the left mouse button to draw a box to the lower right corner of the bay. 
 

Note the features in the bay. Note the black linear feature on the west side of the bay and the radial 
fan pattern in the center of the bay.  Any ideas what might cause that? (It might help if we knew the 
date of the photography.)  Make the Building theme visible.  Can you see any buildings that are not 
included in the Building theme?  Can you be sure they are buildings?  Note what appears to be a 
dock on the north shore of the bay.   Digital orthophotos make an interesting backdrop for the 
feature (vector) data. 

 
The Zoom to Active Theme(s) button can be used to zoom the View to the extent 
of the active theme.  Make the bluewdoq.tif theme active and click on the Zoom to 

Active Theme(s) button. 
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The Digital Raster Graphs (DRGs) are a product of the US Geological Survey.  They are 
scanned versions of the 7.5’ topographic quads.  They are often several years out-of-date, 
based on the most recent revision of the topo sheet. 
 
Make the bluedrg.tif and bluedoq.tif themes visible and all other themes invisible.  Make 
sure the bluedrg.tif themes are on top of the bluedoq.tif themes in the Table of Contents.  
Double-click on the bluewdrg.tif theme to make the theme active and to activate the 
Image Legend Editor.  Select the Colormap button. 
 
Make the following DRG layers transparent (0,1,2,3,5,6,7,8) and change the color of layer 
4 to bright yellow.  The transparent selection is in the upper left corner of the Color 
Palettte (the white box with the x in it).  When finished, click Apply in the Image 
Colormap dialogue box.  This allows contour lines to be displayed in bright yellow over 
the digital orthophoto.  You have created a “quick and dirty” contour map and can better 
visualize the topography of the area. Explore how the contours look at different map 
scales.  Manipulating digital orthophotos and DRGs can create many interesting maps 
that can be used for assessment of development around lakes at the regional scale.   
 
Close the Color Palette, Image Colormap, and Image Legend Editor windows. 
 
Make the Building, Water, and Parcels themes visible and all other themes invisible. 
 

The Zoom to Full Extent button can be used to zoom the View to the extent of all 
themes.  Click on the Zoom to Full Extent button. 

 
Time to save your project.  As you go along, saving your project should become second 
nature. 
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Section 2.  Thematic Mapping of Parcel Attributes 
Estimated time: 45 minutes 
 
In this section, you will join tax roll data to the parcel map through the use of a unique 
parcel identification number (PIN).  You will then be able to display and analyze patterns 
of assessed value and property ownership. 
 
 
Create a new View. 
 
You will create a new View for this section.  Start by making sure you are in the main 
project window.  If you are in the Data Integration View, select the Window pull-down 
menu and choose the current project near the bottom (bluelake.apr).  Make sure the View 
icon is highlighted in the project window and click the New button.  An empty view 
screen will appear entitled View 1.  Use Properties… from the View pull-down menu to 
change the name to “Tax Roll Data View” and set the map and distance units to feet. 
 
You can copy and paste themes between Views, preserving the colors and properties of 
the original theme.  Use the Window pull-down menu to move to the Data Integration 
View.  Make the Buildings, Water, and Parcels themes active. 
 

In order to make multiple themes active, simply hold down the “Shift” key and select each theme.  
All selected themes should be surrounded by a raised box. 

 
Select Copy Themes from the Edit pull-down menu.  Now move to the Tax Roll Data 
View, select Paste from the Edit pull-down menu. 
 
 
Join the Tax Roll database to the Parcels theme. 
 

For each theme added to a view, there is an associated attribute table with 
descriptive information.  You will begin by examining the existing attributes of the 

Parcels theme.  Click the Parcels theme to make it active.   From the Theme pull-down 
menu, select Tables (or click the Open Theme Table button).  When the table opens, 
maximize the screen, scroll through the table, and review the fields. 
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Next, you will need to add the tax roll database file to the project.  The first step is to 
return to the project window.  This is accomplished by selecting the current project 
(bluelake.apr) under the Window pull-down menu.  Next, check to make sure you have 
the Table Icon active in the Project window (or alternatively choose Add Table... from 
the Project pull-down menu).   Click on the Add button.  In the file browser, move to the 
List Files of Type drop-down list and select dBASE(*.dbf).  Select the taxroll96.dbf 
file. When the table opens, take a moment to scroll through the table and review the 
fields. 
 

One of the more useful capabilities of desktop GIS is the ability to view and analyze the spatial 
patterns of information stored in relational databases.  A “join” is a way to match and append 
records between two tables through a common identifier.  In performing the join operation, the 
taxroll96.dbf file will be your source table, and the Attributes of Parcel table will be your 
destination table. 

 
Make sure both tables are open.  The tables are open if you can see them under the 
Window pull-down menu.  Click the title bar of the taxroll96.dbf table or select it from 
the Window pull-down menu to make it the active window.  Click on the Parcel_id field 
title in the taxroll96.dbf table; the title bar will be highlighted in a light gray.  This will 
be the common field joining the two tables together.  Now, select the Attributes of 
Parcels table from the Window pulldown menu to make it active.  This will be the 
destination table.  Click on the Parcel_id field to highlight it. 

 
Finally, click the Join Button in the menu bar to execute the function.  The 

taxroll96.dbf source table is now “dynamically” joined with the Attributes of Parcel 
destination table.  Note the fields in the joined table. 
 
 
Display Assessed Value of the Land from the Tax Roll Database. 
 
Return to the Tax Roll Data View (using the Window pull-down menu).  Make sure the 
Parcels theme is active.  Double-click on the Parcels theme to make the Legend Editor 
active. 
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Choose Graduated Color from the Legend Type: drop-down list.  Choose Total_Land 
from the Classification Field: drop-down list.  It is at the bottom of the list.  Select the 
Classify... button.  Choose Natural Breaks for Type.  Select 4 for the Number of 
Classes.  Click OK.  Choose Chartreuse monochromatic from the Color Ramps: drop-
down list. 
 
Select the Null Value button 
(it looks like a zero with a 
slash through it).  In the Null 
Values dialogue box, select 
Total_Land from the Field 
drop-down list and enter the 
number 0 in the Null Value 
box.  Check the box for 
Display No Data Class.  
Click OK.   
 
Double-click on the symbol 
area next to the 0 value in the 
No Data class to bring up the 
Symbol Palette.  Under the 
Color Palette, select a black 
color for this class.  Click 
Apply in the Legend Editor.  
When finished, close the 
Legend Editor and the 
Symbol Palette. 
 
Under the Theme pull-down menu, use Properties to change the name of the theme to 
Assessed Value of Land.   Examine the View. 
 

The no data values in black represent either a zero value in the tax roll database or where a match 
could not be made between the tax roll database and the Attributes of Parcels table.  What could 
cause matching problems between the two files?  Some possibilities could be typographic errors in 
the unique parcel identification number or subdivision activity that splits or combines parcels and 
assigns them new PINs.  If the digital parcel map and/or the tax roll database are not kept up-to-
date, the number of matching errors is likely to increase. 

 
Use the Edit pull-down menu to make a Copy of the Assessed Value of Land theme.  
Paste it into the Tax Roll Data View.  Make one of the two copies active.  Use Theme 
Properties to rename the theme to “Assessed Value of Land/Area”.  Make this theme 
visible, while turning off the visibility of the “Assessed Value of Land” theme. 
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Double-click on the “Assessed Value of Land/Area” theme to invoke the Legend Editor.  
Modify the legend by selecting Area under the Normalize by: drop-down list.  Choose 
Apply to display the data.  Close the Legend Editor and compare the differences between 
the two parcel themes. 
 

Note that many of the large parcels that have a high total assessed value of land are in the lowest 
category when you examine assessed value per square foot.  Also note that the assessed value of 
the land seems to be highly dependent on the amount of lake frontage.  Finally, note that what 
appear to be fairly similar lakefront parcels on the island actually span a range of assessed values 
of land per square foot. 

 
 
Display Out-of-State Ownership from the Tax Roll Database. 
 
Under the Edit pull-down menu, use the Copy Theme and Paste commands to make a 
copy of the Assessed Value of the Land theme.  Change the theme name of the copy to 
“Property Ownership”.  Make the two Land Value themes invisible. 
 
Make the new “Property Ownership” theme active and invoke the Legend Editor.  In the 
Legend Editor dialogue box, select Unique Value under the Legend Type drop-down 
list.  Select “State” from the Values Field drop-down list. 
 
Select the Null Value button.  In the Null Values dialogue box, select State from the 
Field drop-down list.  Check the box for Display No Data Class.  Click OK. 
 

Click on the Count header at the top of the table.  Then select the Sort Descending 
button (it looks like an upside down staircase).  While in the Legend Editor, 

change the colors for some of the states.  Make ‘WI’ gray, ‘IL’ pink, and the remaining 
states a light green.  Select Apply and close the Symbol Palette and Legend Editor. 
 
With the “Property Ownership” theme active, Select Query from Theme pull-down 
menu.  The zip code for the 
Blue Lake area (Minocqua, 
Wisconsin) is ‘54548’.  
Develop a query ([Zip] = 
“54548”) to select all those 
parcels where the tax bill is 
sent to the local zip code.  
Click on New Set then close 
the window.  You could 
assume that most of these 
are permanent residents on 
Blue Lake.  The selected 
parcels display in yellow. 
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Do you notice any patterns about ownership on the lake?  The eastern side of the lake tends to have 
more out-of-state ownership, while there is more in-state ownership on the western side of the lake.  
There also seem to be clusters of Illinois residents in certain locations on the lake. 

 
Clear the selection from the Property Ownership theme by making this theme active and 
select Clear Selecting Features from the Theme pulldown menu.  Save the project again. 
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Section 3.  Spatial Analysis of Shoreland Zoning Regulations 
Estimated Time: 30 minutes 
 
 
Part 1. Explore a Hypertext Linked Help File of the Shoreland Zoning Ordinance 
 
 Administering a zoning ordinance often requires reference to multiple maps and 
text documents.  Managing these documents in a paper form can become complicated.  
ArcView, in concert with other software packages, can support creation of an “electronic 
zoning ordinance” integrating both text and map.  A Windows help file was created for 
the Oneida County Zoning and Shoreland Protection Ordinance using a software package 
called RoboHelp from Blue Sky Software. 

 
Under the Windows Menu in ArcView, Select bluelake.apr. 
 
If you are using a computer operating system other than Windows (3.1, 95, NT, 
98, 2000, XP), skip this section.  If you are using one of these three systems, 
search for the Windows Help executable program for your operating system.  The 
name of this program varies; try “winhelp.exe” or “winhlp32.exe”.  Typically, 
you will find these files under the following directories which vary by operating 
system: 

Windows 3.1  winhelp.exe    \windows\system\ 
Windows 95  winhlp32.exe     \windows\ 
Windows XP  winhelp.exe   c:\windows\ 
 -or-  winhpl32.exe   c:\windows\system32 
 

When you find this program, note its full pathway name.   
 
From the Project window, highlight the Scripts icon and select New.  Type 
System.Execute(“c:\windows\winhelp.exe c:\ coastgis\bluelake\oneida.hlp”).  
If necessary, substitute the appropriate pathway in your system for the 
“c:\winnt\winhelp.exe” portion of the script and substitute the appropriate 
pathway for the oneida.hlp file to where the downloaded exercise data was 
stored.   

1. Select Properties… under the Script pull-down menu. 
2. Type Open.ZoningText in place of Script1 in the Name field.  Click OK. 
3. Compile the script by selecting the Check Mark icon. 
4. Select the Runner icon to run the program 
5. Select the “Table of Contents” text in underlined, green text to jump to the 

table of contents for the Oneida County Zoning and Shoreland Protection 
Ordinance. 

6. Scroll down to the Waterline Setback section. 
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7. Select the Definitions button at the top of the page to access definitions to all 
the terms in the zoning ordinance. 

8. Select “O” 
9. Select the “ordinary high water mark” hypertext to pop-up a definition for 

that term. 
10. Explore the “Waterline Setback” section of the zoning ordinance. 
11. Close the Electronic Zoning Ordinance. 

 
 
Add a Button to Run the Ordinance from the View GUI 
 

12. Select “bluelake.apr” from the Windows pull-down menu. 
13. Select Customize… from the Project pull-down menu. 
14. In the Customize dialog box, select View in the Type drop-down box and 

Buttons in the Category drop-down box. 
15. Scroll over to the far right side of the box containing the button icons and 

select the Help button that appears as a question mark with an arrow. 
16. Select the New button.  This places a new button on the screen. 
17. Double-Click on the work Click. 
18. Scroll down and select Open.ZoningText in the Script dialog box.  Select 

OK. 
19. Double-Click on the worn Icon. 
20. Select the Load button in the Icon Manager dialog box. 
21. Select Windows Bitmap (.bmp) from the List Files of Type drop-down menu 

and select book.bmp as the icon to display for the button. 
22. Select OK in the Load Icon dialog box.  Select OK in the Icon manager dialog 

box.  Close the Customize dialog box. 
 
A new button with a zoning book icon has been added to the View GUI which launches 
the Oneida County Shoreland Zoning Ordinance when pressed. 
 

Is a zoning ordinance in this form easier to use?  Would it be easier and cheaper for the county to 
distribute the ordinance to the public?  What drawbacks might an ordinance in this form have?   

 
 
Part 2. Waterline Setbacks 
 
You will create a new View for this section.  Start by making sure you are in the main 
project window.  If you are in the Tax Roll Data View, select the Window pull-down 
menu and choose the current project near the bottom (bluelake.apr).  Make sure the View 
icon is highlighted in the project window and click the New button. 
 
An empty view screen will appear entitled View 1.  Use Properties… from the View 
pull-down menu to change the name to “Shoreland Regulations View” and set the map 
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and distance units to feet.  Use the Window pull-down menu to move to the Tax Roll 
Data View.  Make the Buildings, Water, and Property Ownership themes active.  Select 
Copy Themes from the Edit pull-down menu.  Now move to the Shoreland Regulations 
View, select Paste from the Edit pull-down menu.  Double-click on the Property 
Ownership theme to invoke the Legend Editor and under the drop-down list, select Single 
Symbol.  Change the color to light gray.  Under the Theme Properties, change the name 
to Parcels. 
 
 
Find all the Buildings within 75 feet of the Shore. 
 
The Oneida County Zoning and Shoreland Protection Ordinance specifies a waterline 
setback of 75 feet for most structures, in most cases.  To determine which structures are 
within 75 feet of the shore, we will use the Select by Theme command.  The Select by 
Theme command creates a new set of features from a theme (the target theme) based on 
their relationship to another theme (the selector theme).  The target theme must be active 
in the table of contents to begin.  First, make the Building theme active in the table of 
contents (this is the target theme).  In the Theme Menu, choose Select By Theme.  You 
are now in the Select by Theme dialog box. Choose to select features of the active theme 
that Are Within Distance Of.  In the ‘selected features’ drop-down list select Water 
(this is the selector theme).  Enter 75 (feet) for the selection distance.  Click New Set. 
 
Notice that all of the buildings that are within 75 feet of the water are now highlighted in 
yellow. You may need to zoom in to see this. 
 
 
Find Parcels that Contain the Selected Buildings. 
 
There is not much information tagged to buildings, but there are many attributes tied to 
parcels (e.g. property owner mailing address, site address, and assessed value).  In this 
case, the target theme is going to be Parcels, so make sure the Parcels theme is active in 
the table of contents.  As before, in the Theme Menu, choose Select By Theme.  In the 
second drop-down list you want to select Buildings (the selector theme).  Next, in the 
first drop-down list (Select features of active themes that) select Intersect.  Click New 
Set. 
 

Notice that now the parcels are highlighted yellow.  What happens when a structure encroaches on 
a neighboring parcel?  Contemplate what impact errors in spatial data can cause in administration 
of the shoreland zoning ordinance.  

 
Next, we will save the selected set of parcels as a new theme.  With the Parcels theme 
active, select Convert to Shapefile from the Theme pull-down menu.  Save as new file 
as nonconf1.shp in the Convert Parcels dialog box.  Select OK.  Select Yes when 
prompted to add the new shapefile to the view.  Make the Parcels theme active and 
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choose Clear Selected Features from the Theme pull-down menu.  Change the name of 
the new theme to Nonconforming for Waterline Setback and make the theme active. 
 
 
Part 3. Lot Size 
 
The Oneida County Zoning and Shoreland Protection Ordinance specifies a minimum lot 
size of 20,000 square feet for unsewered lots, in most cases.  To determine which parcels 
fall short of this standard, we will use the Query command.  Make the Parcels theme 
active and select Query from the Theme pull-down menu. 
 
In the Query Builder, from the Fields list, double-click [Area] -- this now appears in the 
expression box.  Next, you want to set to a value “less than” 20,000 square feet (click 
once on the ‘<‘ sign).  From the Values list, double click on any number and change it, 
while highlighted in black, to 20000 in the expression builder.  Select the New Set button 
and close the Query Builder window. 
 
Again, we will save the selected set of parcels as a new theme.  Select Convert to 
Shapefile from the Theme pull-down menu.  Save as new file as nonconf2.shp in the 
Convert Parcels dialog box.  Select OK.  Select Yes when prompted to add the new 
shapefile to the view.  Make the Parcels theme active and choose Clear selected features 
from the Theme pull-down menu.  Change the name of the new theme to 
Nonconforming for Lot Size and make the theme active.   
 

Compare the two new themes.  Are there any lots that are both nonconforming for waterline 
setback and lot size? 
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Section 4.  Septic System Maintenance Notification 
Estimated Time: 30 minutes 
 
 
Part 1.  Add an Event Theme of Septic Tank Locations 
 
 Event data sets have a few things in common: they contain a reference to a 
location, a unique identifier, and may contain attributes about that location.  The 
reference to a location could be an XY coordinate, a street address, or a measure along a 
street or other type of route.  In this portion of the exercise, we are going to add an XY 
event to the project that will show the (fictitious) location of septic fields. 
 
You will create a new View for this section.  Start by making sure you are in the main 
project window.  Select the Window pull-down menu and choose the current project 
(bluelake.apr).  Make sure the View icon is highlighted in the project window and click 
the New button.  Use Properties… from the View pull-down menu to change the name 
to “Septic System Maintenance View” and set the map and distance units to feet.  Use the 
Window pull-down menu to move to the “Shoreland Regulations View”.  Make the 
Buildings, Water, and Parcels themes active.  Select Copy Themes from the Edit pull-
down menu.  Now move to the Septic System Maintenance View, select Paste from the 
Edit pull-down menu. 
 
First, you need to import or add the septic field data into the project. .  Select the 
Window pull-down menu and choose the current project.  Click on the Tables icon, then 
select the Add... button.  The Add Table file browser should appear.  Move to the 
c:\coastgis\bluelake directory.  From the List of File Types drop down list, select 
dBASE(*.dbf).  Then select septic.dbf from the list of files.  Click OK to add the file.  
Enlarge the table window and examine the septic data listed.  Note the ‘Construct’ and 
‘Lastpump’ fields.  These represent the year the septic tank was constructed and the year 
the septic tank was last pumped. 
 
Next, you want to make the Septic System Maintenance View screen active.  From the 
View menu, select Add Event Theme.  The Add Event file browser should appear.  
From the Table drop down list select septic.dbf.  Note that the X and Y fields have 
already been selected.  Click OK. 
 
The events are now added to the View screen table of contents.  Click the check box to 
make the Septic events theme visible. To change the theme name in the table of contents, 
select Properties from the Theme menu.  Highlight the Theme Name box and change 
the name to ‘Fictitious Septic Fields’.  Return to the View. 
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Part 2.  Identify the Septic Tanks Last Pumped in 1996 or Before 
 
Participation by counties and other governmental units in the Wisconsin Private Sewage 
System Replacement or Rehabilitation Grant Program administered by the Department of 
Commerce under Wisconsin Administrative Code Comm 87 requires a “maintenance 
program which requires inspection or pumping of all new or replacement private sewage 
systems at least every three years” (Comm 87.60 (5)(b)(4)).  The owner of a private 
sewage system subject to the maintenance program must submit a certification form to 
the appropriate local government unit that states that the system is in proper operating 
condition and that, after inspection and pumping, the tank is less than one-third full of 
sludge and scum. 
 
First, make the ‘Fictitious Septic Fields’ theme active.  Then select Query… from the 
Theme pull-down menu.  Create the expression “Lastpump <= 1996’ and select New Set 
then close the Query window.  Select the Open Theme Table button to view the database.  
A total of 110 of 155 septic tanks should have been selected. 
 
Return to the Septic System Maintenance View.  Make the Parcels theme active in the 
table of contents since this is the theme which lists the owner’s address of the affected 
parcel and septic tank.  Next, from the Theme Menu, select Select by Theme.  Select 
features of the active theme that ‘Intersect’ the selected features of ‘Fictitious Septic 
Fields.’   A total of 97 of the 262 Parcels should have been selected.  To export the table 
with the selected records to an ASCII text file, select Export... from the Attribute Table’s 
File Menu. You should now be in the Export Table dialog box.  Select Delimited Text 
as the type and click OK.  You now want to rename the file as ‘sbnotify.txt’ and save it 
the c:\coastgis\bluelake directory. 
 
After you have identified the properties which contain the septic tanks that need to be 
pumped, you can export this database file and merge it with a form letter using Microsoft 
Word.   
 
Part 3.  Mail Merge a Form Letter in Microsoft Word 
 
 Note: Some computers in the lab may not have Microsoft Word installed.  If this 
is the case, follow along on a different computer for this section. 
 

1. Minimize the ArcView screen and then open Microsoft Word.  From the File 
Menu select Open...  Move to c:/coastgis/bluelake and open the file 
formsept.doc.  This is a form letter created to merge with the database that 
lists the properties affected by the waterline setback. 

2. In the Tools Menu you want to scroll down and select Mail Merge.  A Mail 
Merge Helper box will appear and you want to proceed with Step 1 - Main 
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Document and click Create, and then select form letters.  A question box 
will appear asking if you wish to select the active window or another 
document - click the Active Window button. 

3. Next, proceed to Step 2 in the Main Merge Helper box and click Get Data, 
and then select Open Data Source.  Note that you are in the 
c:\coastgis\bluelake directory.  Then, from the List of File Types drop down 
list select Text Files (*.txt), and then go and select sbnotify.txt.  Select OK.  
A question box will appear stating that no merge fields have been identified; 
click the Edit Main Document button. 

4. In the main document, place the cursor immediately below the line “Oneida 
County Property Owner”, establishing the beginning of the return address 
location.  Then, from the lower left corner of the menu bars select from the 
Insert Merge Field scroll list and select Address1.  Move the cursor to the 
beginning of the next line and then again select from the Insert Merge Field 
Address2.  Repeat this step at the beginning of the next line and then select 
City.  Place a comma and then a space and then, on the same line, insert the 
merge field State.  Follow this with another space and then the merge field 
Zip.   

5. In the final step, go to the Tools Menu again and highlight Mail Merge.  
From the Mail Merge Helper box, proceed to step 3 and click Merge...  The 
Merge Box should appear, simply click the Merge button and the program 
should produce 97 separate form letters for all of the affected properties. 
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Section 5.  Using Hot Links to Aid Zoning Enforcement  
Estimated Time: 15 minutes 
 
Hot links can be utilized to obtain additional information about a feature.  The additional 
information can take the form of an image file, a text file, another ArcView document, or 
a separate ArcView project.  A hot link can also call an Avenue script, which might make 
a system call to run an outside program or perform a complicated series of ArcView 
commands. 
 
You will again create a new View for this section.  Start by making sure you are in the 
main project window.  Select the Window pull-down menu and choose the current 
project.  Make sure the View icon is highlighted in the project window and click the New 
button.  Use Properties… from the View pull-down menu to change the name to “Hot 
Link View” and set the map and distance units to feet.  Use the Window pull-down 
menu to move to the “Shoreland Regulations View”.  Make the Buildings, Water, and 
Parcels themes active.  Select Copy Themes from the Edit pull-down menu.  Now move 
back to the Hot Link View, select Paste from the Edit pull-down menu. 
 
Using the Add Theme button, import the Photos.shp shapefile.  From the Theme Menu, 
select Theme Properties. In the Theme Properties Dialogue Box, select the Hot Link 
icon.  You may need to scroll down in the left window to find it.  Select Image for the 
Field: and Link to Image File for the Predefined Action:.  Select OK. 
 
While back in the View window, make sure the Photos.shp theme is active.  Select the 
Hot Link button (it looks like a lightning bolt).  Click on any of the point features in the 
Photos.shp theme to bring up a photo image of that area. 
 

Other type of files or programs can be hot-linked to features in a theme.  Examples include 
scanned documents, video clips, results of a model run.  What are some other useful files that 
could be hot-linked to the theme we have been using for the Blue Lake shoreland management GIS 
application? 
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Evaluation  
Shoreland Management GIS Training Exercise - Blue Lake, Oneida County, WI 

 
Please complete the following evaluation to help us better understand your experience 
with this tutorial and to increase the effectiveness in future updates to the exercise.  
 
How useful did you find this exercise? 
 □ Very Useful 
 □ Somewhat Useful 
 □ Not very Useful 
 
How would you rank the difficulty of the exercise? 
 □ Too easy 
 □ Just the right level of difficulty 
 □ Very difficult 
  
Were the instructions easy to follow? 
 □ I strongly agree 
 □ I agree 
 □ I disagree 
 □ I strongly disagree 
 □ Not sure 
 
Did you feel the content was appropriate in understanding the GIS applications? 
 □ I strongly agree 
 □ I agree 
 □ I disagree 
 □ I strongly disagree 
 □ Not sure 
 
Would you recommend this exercise to co-works, fellow students, etc? 
 □ Yes 
 □ No 
 □ Maybe 
 
Please add any suggestions that you may have in assisting with the future development 
and updates to this exercise. 
 
 
 
 

 
Please mail this evaluation form to:  University of Wisconsin Sea Grant Institute - Attn: David Hart 

Room 201, Goodnight Hall - 1975 Willow Drive - Madison, WI  53706-1177 


	Allen H. Miller
	
	Madison, WI 53706-1103
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